<>问题描述:

在idea中创建一个Maven项目,运行项目时报:java: 错误: 不支持发行版本 5!

打开Project Structure ,查询Modules的项目jdk版本,发现项目中所有的模块的都变成了5了。

打开File -> Settings -> Buiild,Execution,Deployment -> Compiler -> java compiler
,版本也变成了5。

<>解决方法:

将这个两个地方jdk版本都修改成自己使用的版本,然后保存,就能正常使用了。

缺点:如果再创建一个项目的话,包括之前所有模块项目的jdk又会变成5了,还是会报这个错误,需要自己手动再修改一次。

<>永久解决方法:

修改Maven地址\conf\setting.xml中设置默认jdk版本

我是用的jdk版本是17,已jdk17为例,修改如下:
<profile> <id>development</id> <activation> <jdk>17</jdk> <activeByDefault>true
</activeByDefault> </activation> <properties> <maven.compiler.source>17</
maven.compiler.source> <maven.compiler.target>17</maven.compiler.target> <
maven.compiler.compilerVersion>17</maven.compiler.compilerVersion> </properties>
</profile>

设置完成后保存即可。

<>测试验证:

再次新建Maven项目,项目会默认使用jdk17版本,不用修改即可编译运行成功。

技术
下载桌面版
GitHub
百度网盘(提取码:draw)
Gitee
云服务器优惠
阿里云优惠券
腾讯云优惠券
华为云优惠券
站点信息
问题反馈
邮箱:ixiaoyang8@qq.com
QQ群:766591547
关注微信