码一下,最开始下载了python3.10.4按照博客和b站的教程还是配置不成功,在下载opencv-contrib-python的时候提示n"matching
distribution for opencv-python",试着又下了python3.9.0

一开始同样提示no module named cv

 

然后点击左边的File>settings>点击左上角的➕,下载opencv-python和opencv-contrib-python(下载的时候等了挺久,最后提示successfully)

 点ok以后cv2底下那个红线就没了,就是配置成功了,以后新建项目时候,应用先前的配置解释器(即选中Previously configured
interpreter,interpreter里面就是你刚才配置过opencv的那个解释器,默认不用选了,我装了Python3.10和3.9,所以这选择3.9),之后的项目就可以直接import
cv2,就不用再手动安装包了

 

 

建议:要是直接从官网上下Python默认推荐的是最新版本,要是配置不成功opencv可以试试下早一点的版本,不知道是不是opencv版本还没支持最新版Python的

技术
今日推荐
阅读数 169811
下载桌面版
GitHub
百度网盘(提取码:draw)
Gitee
云服务器优惠
阿里云优惠券
腾讯云优惠券
华为云优惠券
站点信息
问题反馈
邮箱:ixiaoyang8@qq.com
QQ群:766591547
关注微信