<>问题现象

大家知道,一般来说低版本Xcode是无法去调试高版本真机设备的。

我们通常采用的做法是下载最新的iOS DeviceSupport文件,放入Xcode的对应目录中。

但是如果找不到最新的DeviceSupport文件怎么办?

<>问题分析

问题原因很简单,就是缺少对应版本的真机调试支持文件。

一般是从网上下载或者从最新的Xcode中拷贝该文件,但是如果由于新版本推出时间很短,网上还下载不到,或者你又不想下载7、8GB的XCode,又该如何呢?

举个栗子,本篇写作时iOS 13.5.1(17F80)放出才不久,网上是找不到该版本的调试支持文件的。

我开发的本本是12年的MBA,存储只有128GB,几乎已经撑满了,无法下载最新的Xcode,更别说下载后再解压缩了。

我的Xcode 版本是11.3.1,Mac系统版本是Mojave 10.14.6,所以Xcode版本也无法再更新了。

我的真机升级到13.5.1后,用Xcode调试提示当前版本的Xcode无法支持调试13.5.1版本的设备,提示类似如下内容:

The version of iOS on “xxx xxx” does not match any of the versions of iOS
supported for development with this installation of the iOS SDK. Please restore
the devic

技术
友情链接
码工具
Toolsou
API参考文档
云服务器优惠
阿里云优惠券
腾讯云优惠券
华为云优惠券
站点信息
问题反馈
邮箱:ixiaoyang8@qq.com
QQ群:766591547
关注微信